Latest Version 2.2.0.0

Note: Java 8 needs to be installed to use Incogniton.


If you want to use the 32-BIT browser of Incogniton we recommend you to read
this how to first.